Incoming Calls Incident

Incident Report for Platform

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 19:43 BST

Monitoring

Inbound service has been restored and we are monitoring the platform closely
Posted Apr 16, 2025 - 18:18 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2025 - 18:01 BST

Investigating

We are currently investigating this issue impacting some inbound calls, the issue is affecting most UK telecom providers.
Posted Apr 16, 2025 - 16:32 BST
This incident affected: Nuvola PBX.