National Server Upgrade Completion Delay
Incident Report for Platform
Resolved
This incident has been resolved.
Posted Dec 19, 2023 - 08:30 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 19, 2023 - 08:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 19, 2023 - 07:35 UTC
Investigating
We are currently investigating this issue.
Posted Dec 19, 2023 - 07:33 UTC
This incident affected: Go CloudPBX.